Discussion Forums

Customised Distro to run Sonata

7 replies [Last post]
khrm
Offline
Joined: 2011-03-20
Posts: 39

I have build a customised distro to run Sonata based on OpenSuse 11.4 using suse studio.  It simpifies the process of building and installing the sonata.
It has following features:
1) All the dependencies installed except Sun ( or Oracle) Java.
2) Ace libraries are included.
3) A user 'sonata' with permission to sudo without password.
4) In Amazon EC2 format, VMWare format and harddisk format ( for use with dd)

To build sonata follow these steps:
1) Install the OS.
2) Download the sonata using git in home directory.
3) Run sonata_pre in the terminal.
4) Run these lines in the terminal

  • cd ~/SonATA/tclreadline
  • ./reconfig --with-tcl=/usr/lib64 --with-tlib-library="-lncurses" --prefix=$HOME/sonata_install --with-readline-includes=/usr/include/readline
  • make install
  • cd ~/SonATA/CppUnit
  • ./reconfig
  • make
  • sudo make install
  • cd ~/SonATA/sse-pkg
  • ./reconfig
  • make
  • make install
  • cd ~/SonATA/sig-pkg
  • ./reconfig
  • make
  • make install
  • cd ~/SonATA/scripts
  • ./reconfig
  • make
  • make install

Above steps are from Build the Sonata Software section from http://setiquest.org/content/sonata-build.

To test sonata with voyager data run test_sonata

I am yet to this OS. I am still downloading it. I will hopefully test it by Saturday. Anyone else willing to test is welcome

 

khrm
Offline
Joined: 2011-03-20
Posts: 39
I forgot the link to distro.

I forgot the link to distro. It is available here:http://susestudio.com/a/AabtPt/setiquest-desktop

I am thinking of including the step 4) in first post in a script 'sonata_build' .  While this method might not be as as efficient as my single directory nested approach to autoconf used in gsoc port, it reduces the number of build steps further. A user will be able to detect an error if it arises by reading the log which will be generated by the script.

khrm
Offline
Joined: 2011-03-20
Posts: 39
I have found a bug in sudoers

I have found a bug in sudoers file and sudo is not installed( it is because in minimal install it is not install and) . And I will also be updating the sonata_pre file. I will be rebuilding the distro and it will be posted in the above link.

ALso I have not included a webbrowser or any gui editor.  Any one will have to use vi for editing. I will include them later on when I have remove all the errors. It is because they increase the size and my download speed is not high. So I am keeping the size small currently while testing.

jrseti
jrseti's picture
Offline
Joined: 2010-07-22
Posts: 250
I'm back to trying to get

I'm back to trying to get this working. Now I am right at the end trying to run the voyager demo. All the components start up, even the DX and Channelizer. But  sourcing the demo tcl file makes it produce this error:

 

Any thougts on this?

-jrseti

khrm
Offline
Joined: 2011-03-20
Posts: 39
I have faced this error. I

I have faced this error. I can't recall what I did to solve it.  I will look into it. At present my laptop with 4gb ram is at service center and I have desktop with 2gb. So as soon as I get my laptop, I will try to solve it.  ( Hopefully 3-4 days.)

jrseti
jrseti's picture
Offline
Joined: 2010-07-22
Posts: 250
Khrm, I have started a new

Khrm,
I have started a new project. See http://setiquest.org/wiki/index.php/Get_The_SonATA_Distro_Working
Can you help see if we can find the problem.
interestingly, last night SonATA, while observing, got some Dx Errors. They were the same errors as we see here. If we can solve this problem it will possibly make SonATA observations go a bit smoother.
 
 

data collection error:ReceiverTask.cpp:172[routine]
 
Jon

-jrseti

Jay Freeman
Offline
Joined: 2012-08-11
Posts: 1
Efforts by Jay Freeman, 2012.08.11

Hi, this is Jay Freeman, volunteer programmer.  I had a discussion with Jon Richards on 8 August 2012, reviewing his comments here: http://setiquest.org/wiki/index.php/Get_The_SonATA_Distro_Working

Jon suspected that there might be a startup transient with "recvfrom" getting an amount of data that was nonzero, but was not equal to the amount expected.  In the current implementation of Udp::recv (see the wiki page) that would result in that method returning a meaningless value of "errno".  I have been implementing a test modification of "Udp::recv" to investigate, but have had some problems.  The test modification is along the lines of (psuedocode):

    if( recvfrom got the expected number of bytes )
        home free -- return 0 and press on
    else if( recvfrom returned -1 )
        errno is valid, so return it
    else if( recvfrom returned 0 )
        peer has closed its side of connection (shouldn't happen with udp sockets).
   else 
        recvfrom got data, but the wrong amount -- report that condition

Before I go any further, let me reassure you all by stating firmly that I have no intention of checking anything in -- all this is in my local copy of the distro.

That said, my test implementation is clumsy, mainly because it is a debugging hack, but also because I am not getting quite the same error messages as Jon reported on the Wiki page just cited.  When I try to do things, my instance of the distro seems not to get as far as his did:  I get the same errors after typing "test_sonata" and before issuing "source vger-demo-xpol.tcl", but thereafter, things diverge.  A key problem may be an entry in the Message / Error log window:

    bmitDbQuery::error: database is turned off

In any case, in the context of Jon's report on the wiki page, what happens with me is that

    (1) Udp::recv is called for the first time BEFORE I type "source vger-demo-xpol.tcl", and
    (2) its call to "recvfrom" never returns.  (Makes sense if it is waiting for data from a not-turned-on database...)

I am not at all sure what is going on -- my guess is that there is some simple way to turn on the database that is somehow not happening -- or perhaps a race condition of some kind.

My modification of Udp::recv follows:  In it, I have implemented the if/else nest with extensive reporting, using a (static) counter for how many times Udp::recv has been called, and using a special log file in /home/sonata (since I couldn't figure out how the existing logging mechanism worked, and since I was worried that Udp::recv might be called from a process that did not have an attached terminal, so that output to the console might go to the bit bucket).

Error

Udp::recv(void *msg_, size_t len)

{

        static unsigned long recv_try_counter = 0;

        static bool beginning = true;

        static FILE *debug_log_file = 0;

 

        if( beginning ) {

                beginning = false;

                debug_log_file = fopen( "/home/sonata/DebugLog.text", "w" );

                fprintf( debug_log_file, "%s", "Debug log file opened.\n");

                fflush( debug_log_file );

                }

 

        if (connection < 0)

                return (ERR_NS);

 

        char *msg = static_cast<char *> (msg_);

        struct sockaddr_in from;

        socklen_t fromLen = sizeof(from);

 

        ++recv_try_counter;

 

        fprintf( debug_log_file, "\"Udp::recv\" called, instance %lu\n", recv_try_counter );

        fflush( debug_log_file );

        ssize_t len_received = recvfrom(connection, (void *) msg, len,

                                        0, (sockaddr *) &from, &fromLen);

 

        fprintf( debug_log_file, "\"Udp::recv\" has called \"recvfrom\" and \"recvfrom\" has returned, instance %lu\n", recv_try_counter );

        fflush( debug_log_file );

 

        if( len_received == (ssize_t)len ) { // Home free, got what we expected.

                fprintf( debug_log_file, "\"Upd::recv got expected amount of data on try %lu\n",

                         recv_try_counter );

                fflush( debug_log_file );

                return 0;

                }

        else if( len_received == -1 ) {      // recvfrom failed.

                fprintf( debug_log_file, "\"Upd::recv returns errno %d from try %lu\n",

                         errno, recv_try_counter );

                fflush( debug_log_file );

                return errno;

                }

        else if( len_received == 0 ) {       // Peer has closed connection.

                fprintf( debug_log_file, "\"Upd::recv finds peer has closed connection on try %lu\n",

                         recv_try_counter );

                fflush( debug_log_file );

                return errno;

                }

 

        else {                               // Glitch:  Got the wrong amount of data

                fprintf( debug_log_file,

                         "**** GLITCH: \"Upd::recv\" got wrong amount of data on try %lu\n",

                         recv_try_counter );

                fflush( debug_log_file );

                return 0;

                }

}

 

jrseti
jrseti's picture
Offline
Joined: 2010-07-22
Posts: 250
I tried sending to our AWS

I tried sending to our AWS account. It shows up in AWS as Name: empty. And when it tried to start it failed - producing the following log.
 
I told it ot be a "large" instance. I wonder if that is big enough?
 

Xen Minimal OS!
start_info: 0x1890000(VA)
nr_pages: 0x1e0000
shared_inf: 0xbf687000(MA)
pt_base: 0x1893000(VA)
nr_pt_frames: 0x11
mfn_list: 0x990000(VA)
mod_start: 0x0(VA)
mod_len: 0
flags: 0x0
cmd_line: root=/dev/sda1 ro 4
stack: 0x94f860-0x96f860
MM: Init
_text: 0x0(VA)
_etext: 0x5ff6d(VA)
_erodata: 0x78000(VA)
_edata: 0x80b00(VA)
stack start: 0x94f860(VA)
_end: 0x98fe68(VA)
start_pfn: 18a7
max_pfn: 1e0000
Mapping memory range 0x1c00000 - 0x1e0000000
setting 0x0-0x78000 readonly
skipped 0x1000
MM: Initialise page allocator for 27a0000(27a0000)-1e0000000(1e0000000)
MM: done
Demand map pfns at 1e0001000-21e0001000.
Heap resides at 21e0002000-41e0002000.
Initialising timer interface
Initialising console ... done.
gnttab_table mapped at 0x1e0001000.
Initialising scheduler
Thread "Idle": pointer: 0x21e0002010, stack: 0x36f0000
Initialising xenbus
Thread "xenstore": pointer: 0x21e00027c0, stack: 0x3700000
Dummy main: start_info=0x96f960
Thread "main": pointer: 0x21e0002f70, stack: 0x3710000
"main" "root=/dev/sda1" "ro" "4"
vbd 2049 is hd0
******************* BLKFRONT for device/vbd/2049 **********

backend at /local/domain/0/backend/vbd/347/2049
Failed to read /local/domain/0/backend/vbd/347/2049/feature-barrier.
Failed to read /local/domain/0/backend/vbd/347/2049/feature-flush-cache.
31457280 sectors of 512 bytes
**************************

[H
[J Booting 'Ec2 -- SUSE Linux Enterprise Server 11 SP1 - 2.6.32.19-0.3'

root (hd0)

Filesystem type is ext2fs, using whole disk

kernel /boot/vmlinuz-2.6.32.19-0.3-ec2 root=/dev/sda1 xencons=xvc0 console=xvc0

splash=silent showopts

initrd /boot/initrd-2.6.32.19-0.3-ec2

xc_dom_probe_bzimage_kernel: kernel is not a bzImage
close blk: backend at /local/domain/0/backend/vbd/347/2049
[ 0.000000] Initializing cgroup subsys cpuset

[ 0.000000] Initializing cgroup subsys cpu

[ 0.000000] Linux version 2.6.32.19-0.3-ec2 (geeko@buildhost) (gcc version 4.3.4 [gcc-4_3-branch revision 152973] (SUSE Linux) ) #1 SMP 2010-09-17 20:28:21 +0200

[ 0.000000] Command line: root=/dev/sda1 xencons=xvc0 console=xvc0 splash=silent showopts

[ 0.000000] KERNEL supported cpus:

[ 0.000000] Intel GenuineIntel

[ 0.000000] AMD AuthenticAMD

[ 0.000000] Centaur CentaurHauls

[ 0.000000] Xen-provided physical RAM map:

[ 0.000000] Xen: 0000000000000000 - 00000001e0800000 (usable)

[ 0.000000] last_pfn = 0x1e0800 max_arch_pfn = 0x80000000

[ 0.000000] last_pfn = 0x100000 max_arch_pfn = 0x80000000

[ 0.000000] init_memory_mapping: 0000000000000000-0000000100000000

[ 0.000000] init_memory_mapping: 0000000100000000-00000001e0800000

[ 0.000000] RAMDISK: 005a8000 - 01dfb000

[ 0.000000] (4 early reservations) ==> bootmem [0000000000 - 01e0000000]

[ 0.000000] #0 [00005a8000 - 0002d19000] Xen provided ==> [00005a8000 - 0002d19000]

[ 0.000000] #1 [0000002000 - 0000587350] TEXT DATA BSS ==> [0000002000 - 0000587350]

[ 0.000000] #2 [0002d19000 - 000351e000] PGTABLE ==> [0002d19000 - 000351e000]

[ 0.000000] #3 [000351e000 - 0003c26000] PGTABLE ==> [000351e000 - 0003c26000]

[ 0.000000] Zone PFN ranges:

[ 0.000000] DMA 0x00000000 -> 0x00001000

[ 0.000000] DMA32 0x00001000 -> 0x00100000

[ 0.000000] Normal 0x00100000 -> 0x001e0800

[ 0.000000] Movable zone start PFN for each node

[ 0.000000] early_node_map[2] active PFN ranges

[ 0.000000] 0: 0x00000000 -> 0x001e0000

[ 0.000000] 0: 0x001e0800 -> 0x001e0800

[ 0.000000] NR_CPUS:32 nr_cpumask_bits:32 nr_cpu_ids:2 nr_node_ids:1

[ 0.000000] PERCPU: Embedded 17 pages/cpu @ffff880001e07000 s39704 r8192 d21736 u69632

[ 0.000000] pcpu-alloc: s39704 r8192 d21736 u69632 alloc=17*4096

[ 0.000000] pcpu-alloc: [0] 0 [0] 1

[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 1939172

[ 0.000000] Kernel command line: root=/dev/sda1 xencons=xvc0 console=xvc0 splash=silent showopts

[ 0.000000] PID hash table entries: 4096 (order: 3, 32768 bytes)

[ 0.000000] Dentry cache hash table entries: 1048576 (order: 11, 8388608 bytes)

[ 0.000000] Inode-cache hash table entries: 524288 (order: 10, 4194304 bytes)

[ 0.000000] allocated 78725120 bytes of page_cgroup

[ 0.000000] please try 'cgroup_disable=memory' option if you don't want memory cgroups

[ 0.000000] Software IO TLB disabled

[ 0.000000] Memory: 7604740k/7872512k available (2693k kernel code, 8192k absent, 258700k reserved, 2044k data, 208k init)

[ 0.000000] Hierarchical RCU implementation.

[ 0.000000] NR_IRQS:144

[ 0.000000] Xen reported: 2266.746 MHz processor.

[ 0.000000] Console: colour dummy device 80x25

[ 0.000000] console [xvc0] enabled

[ 0.536020] Calibrating delay using timer specific routine.. 4539.67 BogoMIPS (lpj=9079347)

[ 0.536035] pid_max: default: 32768 minimum: 301

[ 0.536092] Security Framework initialized

[ 0.536112] AppArmor: AppArmor initialized

[ 0.536127] Mount-cache hash table entries: 256

[ 0.536225] Initializing cgroup subsys ns

[ 0.536230] Initializing cgroup subsys cpuacct

[ 0.536234] Initializing cgroup subsys memory

[ 0.536241] Initializing cgroup subsys devices

[ 0.536243] Initializing cgroup subsys freezer

[ 0.536245] Initializing cgroup subsys net_cls

[ 0.536288] SMP alternatives: switching to UP code

[ 0.552305] Brought up 1 CPUs

[ 0.552419] devtmpfs: initialized

[ 0.553019] NET: Registered protocol family 16

[ 0.553790] SMP alternatives: switching to SMP code

[ 0.700073] Brought up 2 CPUs

[ 0.700621] bio: create slab <bio-0> at 0

[ 0.701044] suspend: event channel 13

[ 0.701295] xen_mem: Initialising balloon driver.

[ 0.701537] NetLabel: Initializing

[ 0.701540] NetLabel: domain hash size = 128

[ 0.701542] NetLabel: protocols = UNLABELED CIPSOv4

[ 0.701555] NetLabel: unlabeled traffic allowed by default

[ 0.701559] Switching to clocksource xen

[ 0.701668] AppArmor: AppArmor Filesystem Enabled

[ 0.701668] NET: Registered protocol family 2

[ 0.701712] IP route cache hash table entries: 262144 (order: 9, 2097152 bytes)

[ 0.702418] TCP established hash table entries: 262144 (order: 10, 4194304 bytes)

[ 0.703521] TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)

[ 0.703781] TCP: Hash tables configured (established 262144 bind 65536)

[ 0.703787] TCP reno registered

[ 0.703911] NET: Registered protocol family 1

[ 0.703911] Unpacking initramfs...

[ 0.722326] Freeing initrd memory: 24908k freed

[ 0.729496] platform rtc_cmos: registered platform RTC device (no PNP device found)

[ 0.729687] audit: initializing netlink socket (disabled)

[ 0.729703] type=2000 audit(1338916300.700:1): initialized

[ 0.735335] VFS: Disk quotas dquot_6.5.2

[ 0.735373] Dquot-cache hash table entries: 512 (order 0, 4096 bytes)

[ 0.735411] msgmni has been set to 3852

[ 0.735584] alg: No test for stdrng (krng)

[ 0.735634] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 254)

[ 0.735637] io scheduler noop registered

[ 0.735639] io scheduler anticipatory registered

[ 0.735641] io scheduler deadline registered

[ 0.735660] io scheduler cfq registered (default)

[ 0.736593] Xen virtual console successfully installed as xvc0

[ 0.736622] Event-channel device installed.

[ 0.737458] i8042.c: No controller found.

[ 0.737495] mice: PS/2 mouse device common for all mice

[ 0.737740] TCP cubic registered

[ 0.737797] registered taskstats version 1

[ 0.737816] XENBUS: Device with no driver: device/vbd/2049

[ 0.737817] XENBUS: Device with no driver: device/vif/0

[ 0.737914] Freeing unused kernel memory: 208k freed

[ 0.738018] Write protecting the kernel read-only data: 4420k

doing fast boot
[ 0.808036] xen-vbd: registered block device major 8

[ 0.942696] netfront: Initialising virtual ethernet driver.

[ 1.086173] device-mapper: uevent: version 1.0.3

[ 1.086329] device-mapper: ioctl: 4.15.0-ioctl (2009-04-01) initialised: dm-devel@redhat.com

Creating device nodes with udev
[ 1.108381] udevd version 128 started

udevd-event[154]: device node '/dev/mapper/control' already exists, link to '/dev/device-mapper' will not overwrite it

mount: devpts already mounted or /dev/pts busy
mount: according to mtab, devpts is already mounted on /dev/pts

Boot logging started on /dev/xvc0(/dev/console) at Tue Jun 5 17:11:41 2012

[ 1.314349] NET: Registered protocol family 17

Not enough information: "dev" argument is required.

boot/12-network.sh: line 79: /sys/class/net//bonding/miimon: No such file or directory

boot/12-network.sh: line 80: /sys/class/net//bonding/mode: No such file or directory

Not enough information: "dev" argument is required.

[ 1.347376] device-mapper: multipath: version 1.1.0 loaded

[ 1.356540] device-mapper: multipath round-robin: version 1.0.0 loaded

FATAL: Module scsi_dh_emc not found.

FATAL: Module scsi_dh_hp_sw not found.

FATAL: Module scsi_dh_rdac not found.

FATAL: Module scsi_dh_alua not found.

Setup multipath devices: ok.

Trying manual resume from /dev/disk/by-id/scsi-3600508e0000000003e531e0344e6a40b-part2

Trying manual resume from /dev/disk/by-id/scsi-3600508e0000000003e531e0344e6a40b-part2

Waiting for device /dev/sda1 to appear: ok

fsck from util-linux-ng 2.16

[/sbin/fsck.ext3 (1) -- /] fsck.ext3 -a /dev/sda1

/dev/sda1 has gone 616 days without being checked, check forced.

[ 11.242862] sdi: unknown partition table

[ 19.733640] xen-vbd: registered block device major 65

/dev/sda1: 53324/655360 files (0.1% non-contiguous), 339897/2621440 blocks

fsck succeeded. Mounting root device read-write.

Mounting root /dev/sda1

mount -o rw -t ext3 /dev/sda1 /root

[ 89.519523] kjournald starting. Commit interval 15 seconds

[ 89.520270] EXT3 FS on sda1, internal journal

[ 89.520280] EXT3-fs: mounted filesystem with ordered data mode.

[ 89.536493] JBD: barrier-based sync failed on sda1 - disabling barriers

Kdump initrd booted in non-kdump kernel

INIT: version 2.86 booting

System Boot Control: Running /etc/init.d/boot
Mounting sysfs at /sys..done
Mounting debugfs at /sys/kernel/debug..done
Copying static /dev content..done
Mounting devpts at /dev/pts..done

Boot logging started on /dev/xvc0(/dev/console) at Tue Jun 5 17:13:10 2012

Starting udevd: [ 90.162141] udevd version 128 started

..done

Loading drivers, configuring devices: ..done

Activating swap-devices in /etc/fstab...

..doneSetting up the System Clock..done

Activating device mapper...

..done

Loading required kernel modules

..doneWaiting for /dev/sdb . no more events

Checking file systems...

fsck from util-linux-ng 2.16

Checking all file systems.

..doneMounting local file systems...

proc on /proc type proc (rw)

sysfs on /sys type sysfs (rw)

debugfs on /sys/kernel/debug type debugfs (rw)

[ 91.600839] loop: module loaded

devtmpfs on /dev type devtmpfs (rw,mode=0755)

tmpfs on /dev/shm type tmpfs (rw,mode=1777)

devpts on /dev/pts type devpts (rw,mode=0620,gid=5)

mount: special device /dev/sdb does not exist

..failedLoading fuse module [ 91.672126] fuse init (API version 7.13)

..done

Mounting fuse control filesystem..done

Creating /var/log/boot.msg

[ 91.755302] JBD: barrier-based sync failed on sda1 - disabling barriers

..doneActivating remaining swap-devices in /etc/fstab...

..doneSetting up linker cache (/etc/ld.so.cache) using ldconfig..done

Turning quota on

Checking quotas. This may take some time.

..done

Setting current sysctl status from /etc/sysctl.conf..done

Enabling syn flood protection..done

Disabling IP forwarding..done

..done

Mounting securityfs on /sys/kernel/security ..done

Loading AppArmor profiles [ 94.323307] type=1505 audit(1338916394.307:2): operation="profile_load" pid=976 name=/bin/ping

[ 94.347393] type=1505 audit(1338916394.332:3): operation="profile_load" pid=977 name=/sbin/klogd

[ 94.391404] type=1505 audit(1338916394.376:4): operation="profile_load" pid=978 name=/sbin/syslog-ng

[ 94.437783] type=1505 audit(1338916394.420:5): operation="profile_load" pid=979 name=/sbin/syslogd

[ 94.486887] type=1505 audit(1338916394.471:6): operation="profile_load" pid=980 name=/usr/sbin/avahi-daemon

[ 94.589362] type=1505 audit(1338916394.571:7): operation="profile_load" pid=981 name=/usr/sbin/identd

[ 94.633659] type=1505 audit(1338916394.615:8): operation="profile_load" pid=982 name=/usr/sbin/mdnsd

[ 94.684445] type=1505 audit(1338916394.667:9): operation="profile_load" pid=983 name=/usr/sbin/nscd

[ 94.815211] type=1505 audit(1338916394.799:10): operation="profile_load" pid=984 name=/usr/sbin/ntpd

[ 94.855932] type=1505 audit(1338916394.839:11): operation="profile_load" pid=985 name=/usr/sbin/traceroute

..done

Setting up hostname 'linux'..done

Setting up loopback interface lo

lo IP address: 127.0.0.1/8

IP address: 127.0.0.2/8

..done

System Boot Control: The system has been set up

Skipped features:
[80C
[17Dboot.cycle

System Boot Control: Running /etc/init.d/boot.local

..done
INIT: Entering runlevel: 3

Boot logging started on /dev/xvc0(/dev/console) at Tue Jun 5 17:13:15 2012

Master Resource Control: previous runlevel: N, switching to runlevel: 3

Creating universally unique ID.....done

Starting D-Bus daemon..done

Starting syslog services..done

Checking/updating CPU microcode ..unused

Initializing random number generator..done

Loading CPUFreq modules (CPUFreq not supported)

Starting HAL daemon..done

Setting up (localfs) network interfaces:

lo

lo IP address: 127.0.0.1/8

IP address: 127.0.0.2/8

lo

..done eth0

eth0 Starting DHCP4 client.

eth0 IP address: 10.80.126.135/23 (ip-10-80-126-135)

eth0

..doneSetting up service (localfs) network . . . . . . . . . ...done

Starting auditd ..done

Starting rpcbind ..done

Not starting NFS client services - no NFS found in /etc/fstab:..unused

Setting up (remotefs) network interfaces:

Setting up service (remotefs) network . . . . . . . . . ...done

Activating instace...

..done

Generating /etc/ssh/ssh_host_key.

Generating public/private rsa1 key pair.

Your identification has been saved in /etc/ssh/ssh_host_key.

Your public key has been saved in /etc/ssh/ssh_host_key.pub.

The key fingerprint is:

8c:61:cc:3e:e3:05:99:c4:e7:bf:95:cb:5d:df:c7:ba root@ip-10-80-126-135

The key's randomart image is:

+--[RSA1 1024]----+

| .. |

| +.o. |

| Oo |

| o =. |

| = S. . |

| . + . o .|

| . + o oo|

| . o . =|

| Eo.|

+-----------------+

Generating /etc/ssh/ssh_host_dsa_key.

Generating public/private dsa key pair.

Your identification has been saved in /etc/ssh/ssh_host_dsa_key.

Your public key has been saved in /etc/ssh/ssh_host_dsa_key.pub.

The key fingerprint is:

10:9b:32:35:3a:b2:b4:ed:18:8b:f0:18:c1:54:83:d9 root@ip-10-80-126-135

The key's randomart image is:

+--[ DSA 1024]----+

| .=o + |

|oo E.o = |

|..o = + |

| o = + . |

|o + . S |

|.= = |

|o + . |

| |

| |

+-----------------+

Generating /etc/ssh/ssh_host_rsa_key.

Generating public/private rsa key pair.

Your identification has been saved in /etc/ssh/ssh_host_rsa_key.

Your public key has been saved in /etc/ssh/ssh_host_rsa_key.pub.

The key fingerprint is:

24:8a:e7:37:8b:7e:ae:b4:ae:35:96:c1:76:b2:69:89 root@ip-10-80-126-135

The key's randomart image is:

+--[ RSA 1024]----+

| |

| |

| . . |

| o . o |

| . B . S |

| = O |

| E % o |

| = =.o |

| .+*+o |

+-----------------+

Starting SSH daemon..done

Randomizing root password

Changing password for root.

Checking for SSH host key freshness

Fetching User SSH key...

ec2: New key added to authorized keys file from parameters

Scanning scripts ...

Resolve dependencies ...

Install symlinks in /lib/mkinitrd/setup ...

Install symlinks in /lib/mkinitrd/boot ...

Kernel image: /boot/vmlinuz-2.6.32.19-0.3-ec2

Initrd image: /boot/initrd-2.6.32.19-0.3-ec2

Root device: /dev/sda1 (mounted on / as ext3)

Kernel Modules: cdrom xenblk jbd mbcache ext3 xennet

Features: EC2 block resume.userspace resume.kernel

24622 blocks

Update repository configuration...

Updating AMI tools...

ec2: Signature check failed for ec2-ami-tools

ec2: Unable to update ec2-ami-tools

..failed

Starting irqbalance ..done

Starting Name Service Cache Daemon..done

Starting mail service (Postfix)..done

Starting CRON daemon..done

Starting smartd ..unused

ec2: -----BEGIN SSH HOST KEY FINGERPRINTS-----

ec2: 1024 8c:61:cc:3e:e3:05:99:c4:e7:bf:95:cb:5d:df:c7:ba /etc/ssh/ssh_host_key.pub (RSA1)

ec2: 1024 24:8a:e7:37:8b:7e:ae:b4:ae:35:96:c1:76:b2:69:89 /etc/ssh/ssh_host_rsa_key.pub (RSA)

ec2: 1024 10:9b:32:35:3a:b2:b4:ed:18:8b:f0:18:c1:54:83:d9 /etc/ssh/ssh_host_dsa_key.pub (DSA)

ec2: -----END SSH HOST KEY FINGERPRINTS-----

..done

Master Resource Control: runlevel 3 has been reached

Failed services in runlevel 3:
[80C
[13Damazon

Skipped services in runlevel 3:
[80C
[38Dmicrocode.ctl nfs splash smartd

Welcome to SUSE Linux Enterprise Server 11 SP1 (x86_64) - Kernel 2.6.32.19-0.3-ec2 (xvc0).

ip-10-80-126-135 login:
INIT: Switching to runlevel: 0

INIT: Sending processes the TERM signal

Boot logging started on /dev/xvc0(/dev/console) at Tue Jun 5 17:25:02 2012

Master Resource Control: previous runlevel: 3, switching to runlevel: 0

..done

..done

Shutting down auditd ..done

Shutting down CRON daemon..done

Shutting down irqbalance ..done

Shutting down Name Service Cache Daemon..done

Saving random seed..done

Deactivating instace...

..done

Shutting down smartd ..done

Shutting down SSH daemon..done

Shutting down mail service (Postfix)..done

Shutting down (remotefs) network interfaces:

Shutting down HAL daemon..done

Shutting down NFS client services:..done

Shutting down rpcbind ..done

Shutting down syslog services..done

Shutting down (localfs) network interfaces:

eth0

eth0

..doneShutting down service (localfs) network . . . . . . . . ...done

Shutting down D-Bus daemon..done

Running /etc/init.d/halt.local

..doneUnmounting fuse control filesystem..done

Turning off quota

..done

..done

Turning off swap files

Unloading AppArmor profiles ..done

Unmounting file systems

/dev/sdt1 umounted

..doneStopping udevd: ..done

Sending all processes the TERM signal...

..done

..done
The system will be halted immediately.
[ 808.115995] System halted.

 

https://d1ge0kk1l5kms0.cloudfront.net/images/G/01/webservices/console/bu...); background-color: transparent; margin: auto 2px; text-align: left; width: 75px; background-position: 0px 0px; background-repeat: no-repeat no-repeat; ">Close

 

https://d1ge0kk1l5kms0.cloudfront.net/images/G/01/webservices/console/po...); background-attachment: scroll; background-color: transparent; background-position: 0px 0px; background-repeat: no-repeat repeat; ">
 

https://d1ge0kk1l5kms0.cloudfront.net/images/G/01/webservices/console/po...); background-attachment: scroll; color: rgb(0, 0, 0); font-family: Verdana, Arial, sans-serif; line-height: 12px; text-align: left; background-position: 0px 0px; background-repeat: no-repeat no-repeat; ">
 

 

-jrseti